Hallo aus Aachen

Hier kann jeder eine kurze Vorstellung über sich verfassen ...

Moderator: Franz

Benutzeravatar

detlef
Rank 12
Rank 12
Beiträge: 1338
Registriert: Do 28. Mär 2019, 09:10
Wohnort: Fronhausen (bei Marburg)
Hauptanschluß: 7822222 hael d

Re: Hallo aus Aachen

#11

Beitrag von detlef »

FelixF hat geschrieben:
Di 15. Sep 2020, 22:09
Achso, danke für die Infos. Die I-Telex Bauteile kommen bald. Da brauche ich keinen Server anzumieten, dafür gibt es den Centralex Server. Braucht man für den Centralex DynDns?
Nein. Für Centralex muss du nicht erreichbar sein.
Gruß, Detlef

i-Telex: 7822222 (T1000), 211230 (T100Z), 96868 (T37)
Konferenzdienst: 11160 (de) / 11161 (en)
Auskunft 1987: 40140

Benutzeravatar

FelixF
Rank 8
Rank 8
Beiträge: 124
Registriert: Di 30. Jun 2020, 23:04
Hauptanschluß:

Re: Hallo aus Aachen

#12

Beitrag von FelixF »

Ach, schön. Mehr sicherheit fürs i-Telex und unkomplizirter :)
MFG Felix
----------------------------------------
1. 33397 felix d -nicht von aussen erreichbar

Benutzeravatar

BjoernS
Rank 7
Rank 7
Beiträge: 82
Registriert: Mi 6. Mai 2020, 21:25
Wohnort: Darmstadt
Hauptanschluß: 844767 twtr d

Re: Hallo aus Aachen

#13

Beitrag von BjoernS »

Hallo Rolf,

tolle Arbeit! :thumbsup:

Hatte mich schon mit Jochen besprochen (Reim unbeabsichtigt), wenn die akuten Sachen gelöst sind ist eine native IPv6-Unterstützung für piTelex angedacht.

Auf lange Sicht wäre natürlich eine Lösung am besten, die keine Serveranmietung erfordert. Da die "i-Telex-Fauna" auf IPv4 ausgelegt ist, und die Implementierung von IPv6 auf den Atmels der i-Telex-Ethernetkarten vmtl. mit großen Schmerzen verbunden sein würde, könnte das Thema z.B. mit einem kleinen Raspi-Adapter gelöst werden, der LAN einen IPv4-Weg zum Centralex bietet.

Ggf. wäre zum Thema mal ein Entwickler-"Hirnstürmen" vor dem samstäglichen Kaffeekränzchen angesagt, wer hätte Interesse?

Grüße


Björn
Folgende Benutzer bedankten sich beim Autor BjoernS für den Beitrag:
obrecht
844767 twtr d

Benutzeravatar

FredSonnenrein
Developer
Developer
Beiträge: 1354
Registriert: Fr 3. Jun 2016, 13:49
Wohnort: Braunschweig
Hauptanschluß: 8579924 hawe d

Re: Hallo aus Aachen

#14

Beitrag von FredSonnenrein »

obrecht hat geschrieben:
Di 15. Sep 2020, 18:11
Hallo Detlef,
jaaaa.... das war nicht so einfach, da meine Fritzbox nur über DS-Lite ans Internet geht mit carrier-grade-NAT. Vom Netz ist der itelex-Rechner deshalb nur über IPV6 erreichbar. Also hab ich mir einen Tunnel für IPV4 gebastelt. IPV6 hätte eigentlich auch gereicht, aber die PiTelex-Software ist wohl (noch) nicht IPV6-aware.

IP-Adresse und Port sind 185.163.119.220:2342

Ich komme vom Netz aus mit netcat mit diesen Angaben auch auf die Maschine und kann sie als remote-Drucker missbrauchen :-) Also sollte es doch eigentlich laufen können, oder?
Viele Grüße
Rolf
Ich habe dich jetzt eingerichtet. Du hast aber die "Dyn-IP-Methode" aktiviert. Bist du sicher, dass das mit dem Tunnel dann auch funktioniert? Welche IP sieht ein Empfänger, wenn deine Pitelex-Station eine Verbindung aufbaut?

Nachtrag: Der Teilnehmer-Server sieht nicht die Adresse 185.163.119.220 von dir, sondern die 5.146.194.194. Offensichtlich gehen ausgehende Verbindungen nicht über den Tunnel.
Folgerung: Ich kann die 185.163.119.220 fest eintragen, wenn du die "Dyn-IP-Funktion" des Pi-Telex deaktivierst.
Grüße,
Fred Sonnenrein, Braunschweig
i-Telex 952741 (Lo133), 531075 (Creed75), 8579924 (T100s), 792911 (T68d) oder 781272 (T100 75Baud)
Bei Besetzt bitte 531002 versuchen.

Benutzeravatar

Topic author
obrecht
Rank 2
Rank 2
Beiträge: 13
Registriert: Fr 26. Jun 2020, 18:53
Wohnort: Aachen
Hauptanschluß: 833539 fili d

Re: Hallo aus Aachen

#15

Beitrag von obrecht »

FredSonnenrein hat geschrieben:
Mi 16. Sep 2020, 11:01

Ich habe dich jetzt eingerichtet. Du hast aber die "Dyn-IP-Methode" aktiviert. Bist du sicher, dass das mit dem Tunnel dann auch funktioniert? Welche IP sieht ein Empfänger, wenn deine Pitelex-Station eine Verbindung aufbaut?

Nachtrag: Der Teilnehmer-Server sieht nicht die Adresse 185.163.119.220 von dir, sondern die 5.146.194.194. Offensichtlich gehen ausgehende Verbindungen nicht über den Tunnel.
Folgerung: Ich kann die 185.163.119.220 fest eintragen, wenn du die "Dyn-IP-Funktion" des Pi-Telex deaktivierst.
Hallo Fred,

danke fürs Eintragen und die Mühe beim Testen. Deine Bedenken kann ich -glaube ich- entkräften:
DynIP brauche ich nur für den Tunnel von 185.163.119 zum pitelex-Rechner hinter der Fritzbox. Das hat mit der "Außenansicht" nichts zu tun.

5.146.194.194 ist die IPV4 des vodafone-gateways und das Ende des CGN.
Und ja klar, bei ausgehenden Verbindungen wird der IPV4-in-IPV6-Tunnel des Providers genutzt, aber das macht ja nichts, denn der Angerufene braucht ja nicht diese IP zur Identifikation des Anrufers, sondern den KG, und die Verbindung funktioniert in beiden Richtungen (habe ich mit dem DWD-Server mehrfach und auch mit Jochen probiert).

Um mich über i-Telex anzurufen, braucht der Anrufer die Kenntnis des empfangenden Hosts/Ports und das ist und bleibt statisch 185.163.119:2342.
Das ganze DynIP-Geraffel dazwischen sind nur interne Kniffe zum Aufbau des Tunnels durch die Fritzbox zum Raspberry. Der Anrufer weiss davon nichts und muss davon auch nichts wissen.

"833539 fili d" ist über die statische IPV4-Adresse 185.163.119:2342 zu erreichen, also sollte die m.E. im Teilnehmerverzeichnis stehen.
Die 5.146.194.194 ist egal und braucht nirgendwo aufzutauchen.

Oder habe ich jetzt was Essentielles übersehen?

VG Rolf
Rolf
----------------------------------------
833539 fili d T100a mit FSG 'NL'

Benutzeravatar

FredSonnenrein
Developer
Developer
Beiträge: 1354
Registriert: Fr 3. Jun 2016, 13:49
Wohnort: Braunschweig
Hauptanschluß: 8579924 hawe d

Re: Hallo aus Aachen

#16

Beitrag von FredSonnenrein »

Hallo Rolf,
obrecht hat geschrieben:
Mi 16. Sep 2020, 13:05
Oder habe ich jetzt was Essentielles übersehen?
Ja. Irgendwas in deinem PiTelex sendet an den Teilnehmerserver regelmäßig ein "DynIP-Datenpaket" mit dem sinngemäßen Inhalt:

"Hier ist der Anschluss 833539. Bitte aktualisiere die IP-Adresse dieses Anschlusses auf die IP-Adresse, die als Absender dieses Datenpakets erscheint".

Diese Funktion benötigen die "normalen" i-Telex-Nutzer mit nicht-statischer IP, damit sie trotz Wechsel der Adresse erreichbar bleiben.

Wenn ich beim Teilnehmerserver deinen Datensatz auf "feste IP-Adresse" ändere, dann wird der Empfang des DynIP-Datenpakets eine Fehlermeldung an alle Server-Administratoren gesendet.

Wenn ich beim Teilnehmerserver deinen Datensatz so lasse wie es ist, dann wird wieder die 'falsche' IP-Adresse eingetragen werden.

Also: Bitte die "DynIP-Funktion" bei dir abschalten. Wie das geht, kann dir nur der Entwickler des PiTelex sagen.

Grüße,

Fred
Folgende Benutzer bedankten sich beim Autor FredSonnenrein für den Beitrag:
obrecht
Grüße,
Fred Sonnenrein, Braunschweig
i-Telex 952741 (Lo133), 531075 (Creed75), 8579924 (T100s), 792911 (T68d) oder 781272 (T100 75Baud)
Bei Besetzt bitte 531002 versuchen.

Benutzeravatar

Topic author
obrecht
Rank 2
Rank 2
Beiträge: 13
Registriert: Fr 26. Jun 2020, 18:53
Wohnort: Aachen
Hauptanschluß: 833539 fili d

Re: Hallo aus Aachen

#17

Beitrag von obrecht »

FredSonnenrein hat geschrieben:
Mi 16. Sep 2020, 13:36
Hallo Rolf,
obrecht hat geschrieben:
Mi 16. Sep 2020, 13:05
Oder habe ich jetzt was Essentielles übersehen?

Also: Bitte die "DynIP-Funktion" bei dir abschalten. Wie das geht, kann dir nur der Entwickler des PiTelex sagen.

Grüße,

Fred
AH. Problem verstanden. Der piTelex soll einfach "stillschweigen", dann ist das Problem gelöst, solange die im TN-Server händisch eingetragene Adresse statisch ist und sich nicht ändert. Richtig? Ich muss also in der PiTelex-Software den Knopf zum Ausschalten der update-Meldungen suchen.

VG
Rolf
Rolf
----------------------------------------
833539 fili d T100a mit FSG 'NL'

Benutzeravatar

BjoernS
Rank 7
Rank 7
Beiträge: 82
Registriert: Mi 6. Mai 2020, 21:25
Wohnort: Darmstadt
Hauptanschluß: 844767 twtr d

Re: Hallo aus Aachen

#18

Beitrag von BjoernS »

FredSonnenrein hat geschrieben:
Mi 16. Sep 2020, 13:36
Also: Bitte die "DynIP-Funktion" bei dir abschalten.
... dafür in telex.json im Abschnitt i-Telex den Eintrag "number" auf der Standardeinstellung 0 belassen ("tns-pin" wird dann ignoriert):

Code: Alles auswählen

 "i-Telex": {
      "type": "i-Telex",
      "enable": true,
      "port": 2342,
      "number": 0,
      "tns-pin": 12345
    },
Grüße


Björn

P.S.: Die zugehörige Doku ist in Arbeit ... :schwitz: Der Konfi-Eintrag wäre mit einem Namen wie "tns-dynip-number" anschaulicher. Ich werde das anpassen.
Folgende Benutzer bedankten sich beim Autor BjoernS für den Beitrag:
obrecht
844767 twtr d

Benutzeravatar

FredSonnenrein
Developer
Developer
Beiträge: 1354
Registriert: Fr 3. Jun 2016, 13:49
Wohnort: Braunschweig
Hauptanschluß: 8579924 hawe d

Re: Hallo aus Aachen

#19

Beitrag von FredSonnenrein »

Hallo Rolf,
obrecht hat geschrieben:
Mi 16. Sep 2020, 14:53
AH. Problem verstanden. Der piTelex soll einfach "stillschweigen", dann ist das Problem gelöst, solange die im TN-Server händisch eingetragene Adresse statisch ist und sich nicht ändert. Richtig? Ich muss also in der PiTelex-Software den Knopf zum Ausschalten der update-Meldungen suchen.
Richtig. Bitte gib kurz Bescheid, wenn du die Änderung gemacht hast. Und nochmal angeben, welchen Port du möchtest.
Grüße,
Fred Sonnenrein, Braunschweig
i-Telex 952741 (Lo133), 531075 (Creed75), 8579924 (T100s), 792911 (T68d) oder 781272 (T100 75Baud)
Bei Besetzt bitte 531002 versuchen.

Benutzeravatar

Topic author
obrecht
Rank 2
Rank 2
Beiträge: 13
Registriert: Fr 26. Jun 2020, 18:53
Wohnort: Aachen
Hauptanschluß: 833539 fili d

Re: Hallo aus Aachen

#20

Beitrag von obrecht »

Mach ich. Hab eben Jochen angeschrieben mit der Bitte um Hilfe. Sobald ich was weiß, melde ich mich.
Danke jedenfalls und VG
Rolf
Rolf
----------------------------------------
833539 fili d T100a mit FSG 'NL'

Antworten

Zurück zu „Benutzer-Vorstellungen“